Ticket #1044 (closed defect: worksforme)

Opened 10 years ago

Last modified 9 years ago

FF will soon include Windows-esque UAC

Reported by: jdreed Owned by:
Priority: normal Milestone: The Distant Future
Component: -- Keywords:
Cc: Fixed in version:
Upstream bug:

Description

davidben pointed us at  https://blog.mozilla.com/addons/2011/08/11/strengthening-user-control-of-add-ons/
Specifically, it looks like it will require the user to explicitly opt-in to extensions installed on disk by other packages (i.e. us).

Change History

comment:1 Changed 10 years ago by jdreed

This may be Windows-only?

comment:2 Changed 10 years ago by davidben

 https://blog.mozilla.com/addons/2011/08/11/strengthening-user-control-of-add-ons/#comment-153557

This suggests it'll be everywhere, and there'll be some mechanism for "enterprises and other distributions" which is probably the appropriate use case. I imagine it'll be on that blog. It's slated for Firefox 8 which is planned for stable around November 8th or so.

 https://wiki.mozilla.org/RapidRelease/Calendar

comment:3 Changed 10 years ago by davidben

And I can confirm it does exist on Linux; got a dialog for ubufox. If you try the current Aurora channel, you can experiment. (I always pass -P firefox-aurora to not clobber my usual profile.) Not clear yet what's the official mechanism for Debathena's use case. If they've posted info on it, I haven't found it.

 http://www.mozilla.org/en-US/firefox/channel/

comment:4 Changed 10 years ago by jdreed

So it does indeed look like FF 8 will give us this. Yay.

Can we give up on the extension and do everything in a wrapper script? I think we can, modulo the "Athena On-Line Help" entry in the Help menu, but nobody uses menus anyway, anymore. We can at least do network.negotiate-auth.trusted-uris and all the other prefs. And can probably do something awesome with certutil.

comment:5 Changed 10 years ago by davidben

As a heads-up, Firefox 7 was just released. Looks like 8 is still planned for early November. This might bite before animal-that-starts-with-P.

Maybe pester the Mozilla folks to see what they recommend? I haven't found the mechanism for "enterprises and other distributions" alluded to in their comment, and perhaps they have a better solution for setting default preferences and such.

comment:6 Changed 10 years ago by davidben

And Firefox 8 is out the door.

comment:7 Changed 10 years ago by jdreed

FF 9 is out. Yay.

comment:8 Changed 10 years ago by jdreed

Since this is the ticket where we're tracking Mozilla's craziness:

 http://blog.mozilla.com/blog/2012/01/10/delivering-a-mozilla-firefox-extended-support-release/

comment:9 Changed 9 years ago by jdreed

  • Milestone changed from Precise Beta to The Distant Future

So, nothing yet broke on Precise regarding the extension. I suspect as long as we continue to do what ubufox does, we'll be fine. I'm going to keep this open in case I'm missing something subtle.

comment:10 Changed 9 years ago by jdreed

  • Status changed from new to closed
  • Resolution set to worksforme
Note: See TracTickets for help on using tickets.