Ticket #1057 (closed defect: duplicate)

Opened 10 years ago

Last modified 8 years ago

/etc/apparmor.d/tunables/home.d transition not managed well

Reported by: geofft Owned by:
Priority: normal Milestone: The Distant Future
Component: -- Keywords:
Cc: Fixed in version: debathena-apparmor-config 1.2.3
Upstream bug:

Description

We have the following code in apparmor-config's debian/rules:

ifneq ($(wildcard /etc/apparmor.d/tunables/home),)
    ifeq ($(wildcard /etc/apparmor.d/tunables/home.d),)
        # Needed for anything older than Lucid
        DEB_TRANSFORM_FILES_debathena-apparmor-config += /etc/apparmor.d/tunables/home.debathena
    endif
endif

However, nothing explicitly undiverts /etc/apparmor.d/tunables/home on upgrade to Lucid (or later). This appears to leave our pre-Lucid transformed version in place, and the package's new file in home.debathena-orig.dpkg-new.

Change History

comment:1 Changed 10 years ago by andersk

Dupe of #866?

(BTW, If you’re wondering which of these undivert tickets to work on first, this one has caused problems on real systems.)

comment:2 Changed 9 years ago by jdreed

Again, this was already done (14 months before this ticket was filed. Was it just that we never managed to build it, or had version skew or something?

 24726     broder 	if [ -d /etc/apparmor.d/tunables/home.d ]; then
 24726     broder 	    cleanup_old_diversion /etc/apparmor.d/tunables/home
 24726     broder 	fi

comment:3 Changed 8 years ago by jdreed

  • Status changed from new to closed
  • Resolution set to duplicate

comment:4 Changed 8 years ago by jdreed

  • Fixed in version set to debathena-apparmor-config 1.2.3
Note: See TracTickets for help on using tickets.