Ticket #107 (closed defect: worksforme)

Opened 13 years ago

Last modified 13 years ago

Printing from acroread broken

Reported by: kchen Owned by:
Priority: normal Milestone:
Component: Keywords:
Cc: Fixed in version:
Upstream bug:

Description

On my feisty machine, printing from acroread is broken:

Traceback (most recent call last):

File "/usr/bin/lpr", line 131, in <module>

fn(*fn_args)

File "/usr/bin/lpr", line 63, in useCups

if queue == None or cupsQueueExists(queue) or not lprngQueueExists(queue):

File "/usr/bin/lpr", line 45, in cupsQueueExists

return returnCode('/usr/bin/lpq.debathena-orig', '-P%s' % queue) == 0

File "/usr/bin/lpr", line 40, in returnCode

return call(command, stdout=PIPE, stderr=PIPE)

File "/usr/lib/python2.5/subprocess.py", line 443, in call

return Popen(*popenargs, kwargs).wait()

File "/usr/lib/python2.5/subprocess.py", line 1166, in wait

pid, sts = self._waitpid_no_intr(self.pid, 0)

File "/usr/lib/python2.5/subprocess.py", line 1007, in _waitpid_no_intr

return os.waitpid(pid, options)

OSError: [Errno 10] No child processes

Printing from other programs works fine.

Change History

comment:1 Changed 13 years ago by broder

Kevin (or anyone), is this still reproducible on newer distributions?

comment:2 Changed 13 years ago by broder

  • Status changed from new to closed
  • Resolution set to worksforme

I can't reproduce this on Hardy.

Note: See TracTickets for help on using tickets.