Ticket #1076 (closed task: fixed)

Opened 10 years ago

Last modified 10 years ago

Get rid of -branding packages

Reported by: geofft Owned by:
Priority: normal Milestone: Precise Alpha
Component: -- Keywords:
Cc: Fixed in version:
Upstream bug:

Description

GDM 2 is slowly dying. More importantly, there appears to be  a consensus on debian-devel to make Policy disallow circular dependencies for the benefit of dependency resolvers. This won't happen any time soon (mostly because perl/perl-modules needs to be sorted out) but it looks fairly inevitable, and we'd like resolvers with this assumption not to break when encountering our metapackages.

I believe that our only circular dependencies are in -branding packages, based on the following aptitude query:

geofft@leveret:~$ aptitude search '~Odebathena ?for x: ~D~D?=x'
p   debathena-cluster               - Athena cluster configuration for Debian   
p   debathena-cluster-branding      - Displays which Debathena metapackage level
p   debathena-login-graphical       - Athena graphical login configuration      
p   debathena-login-graphical-brand - Displays which Debathena metapackage level
p   debathena-workstation           - Athena managed workstation configuration  
p   debathena-workstation-branding  - Displays which Debathena metapackage level

Change History

comment:1 Changed 10 years ago by jdreed

The branding packages have been no-ops for a while now, in the new-gdm world. Can we just punt them entirely and clean up the crap that is the rules file? Or do we have to continue to pretend to support ancient GDM for Squeeze?

comment:2 Changed 10 years ago by jdreed

  • Status changed from new to committed
  • Milestone changed from The Distant Future to Precise Alpha

r25502 punts the branding packages, and changes the old-GDM theme to simply display the word "Debathena" on the login screen where the metapackage used to be displayed.

We can then kill old-GDM later, but this at least gets rid of the circular dependencies.

comment:3 Changed 10 years ago by jdreed

  • Status changed from committed to development

gdm-config 1.36 is in development. This punts the -branding packages, and "Provides" them.
Also in -development are cluster 1.11, workstation 1.7, and login-graphical 1.1, all of which remove the dependency on the -branding packages.

I think there's no harm in gdm-config continuing to "Provide" the branding packages. Thoughts?

This should not get moved until 5/28.

comment:4 Changed 10 years ago by jdreed

  • Status changed from development to proposed

comment:5 Changed 10 years ago by jdreed

  • Status changed from proposed to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.