Ticket #1117 (closed task: fixed)

Opened 10 years ago

Last modified 9 years ago

errant cyrus-sasl2-mit in squeeze archive

Reported by: geofft Owned by:
Priority: normal Milestone: The Distant Future
Component: -- Keywords:
Cc: Fixed in version:
Upstream bug:

Description

While doing the wheezy build (with psuite=squeeze), bbaren and I noticed that deps.mk/build-all seems to think that we need to build cyrus-sasl2-mit. We stopped debathenifying this ages ago, but apparently this is still listed in the apt repository in some way, and so gen-build-deps thinks that we should rebuild it (see the generated dependency of debathena-build-depends on everything in psuite at the bottom of gen-build-deps).

apt-cache madison confirms that it's there:

tyger:~ geofft$ apt-cache madison cyrus-sasl2-mit
cyrus-sasl2-mit | 2.1.22.dfsg1-0debathena2 | http://debathena.mit.edu/apt/ squeeze/debathena Sources

We should explicitly remove it from the apt archive.

Change History

comment:1 Changed 9 years ago by jdreed

  • Status changed from new to closed
  • Resolution set to fixed

Why did it take us 7 months to do this, particularly as it only ever existed as a source package in squeeze?

$ dareprepro removesrc squeeze cyrus-sasl2-mit
removing 'cyrus-sasl2-mit' from 'squeeze|debathena|source'...
Exporting indices...
Successfully created '/mit/debathena/apt/dists/squeeze/Release.gpg.new'
Successfully created '/mit/debathena/apt/dists/squeeze/InRelease.new'
Note: See TracTickets for help on using tickets.