Ticket #1142 (closed defect: invalid)

Opened 9 years ago

Last modified 9 years ago

-workstation should not install build-depends

Reported by: jdreed Owned by:
Priority: high Milestone: Precise Beta
Component: -- Keywords:
Cc: Fixed in version:
Upstream bug:

Description

If you want to build Debathena software, go install build-depends yourself. This currently leads to stupid things like the maybe-foo packages being installed, and requires aptitude's dependency resolver to resolve the ubufox->xul-ext-ubufox transition, when that shouldn't have been necessary.

Change History

comment:1 Changed 9 years ago by jdreed

Hrm, I was going to put this back into extra-software,except, uh, we removed it from extra-software-nox a while ago.

I think my objection is actually to the maybe-foo packages. Or possibly even to the fact that we didn't update the maybe-ubufox package for the rename. Certainly having autogoo installed on workstations is reasonable, as are things like libx11-dev, etc, and our various -dev libraries. And arguably, you should be able to build some Athena packages on workstation/cluster.

comment:2 Changed 9 years ago by jdreed

  • Status changed from new to closed
  • Resolution set to invalid
Note: See TracTickets for help on using tickets.