Ticket #1201 (closed defect: fixed)

Opened 9 years ago

Last modified 9 years ago

telepathy-mission-control-5 is crashy

Reported by: kaduk Owned by:
Priority: normal Milestone: Quantal Quetzal
Component: -- Keywords:
Cc: Fixed in version:
Upstream bug:  LP:1024848

Description

On precise, we seem to pretty frequently get notification popups that it has segfaulted, sometimes in exciting places like fclose(). Looking at launchpad, there are a lot of segfaults reported against it, indicating that its memory management is pretty terrible.
It's Depended on by empathy, which is in turn Recommended by ubuntu-desktop.
It's unclear if we can get away with punting empathy from the release, but we should probably do something so that our users don't get bombarded by these notifications.

Change History

comment:1 follow-up: ↓ 2 Changed 9 years ago by jdreed

I'm kind of curious to know how this starts (dbus helper? gnome-mumble?), and whether this happens primarily on cluster, workstation, etc? It's been running on my workstation machine for over 3 weeks now with no issues. If this is just cluster, and it's started by the dbus helper, then we can trivially just not start it.

Other stupid ideas involve diverting either its dbus service description or the executable itself. Short of making debathena-cluster Conflict empathy (#ActuallyTheWorstIdeaEver?), I don't have any other ideas.

comment:2 in reply to: ↑ 1 Changed 9 years ago by kaduk

Replying to jdreed:

I'm kind of curious to know how this starts (dbus helper? gnome-mumble?), and whether this happens primarily on cluster, workstation, etc? It's been running on my workstation machine for over 3 weeks now with no issues. If this is just cluster, and it's started by the dbus helper, then we can trivially just not start it.

I mentioned this on zephyr, but repeating here for completeness.
I've seen it a few times on my workstation VM. I don't (yet) have a good sense of what triggers it, though actually attempting to run empathy has produced crashes for me the once or twice I tried.

comment:3 Changed 9 years ago by andersk

  • Status changed from new to closed
  • Upstream bug set to LP:1024848
  • Resolution set to fixed

I’m going to assume for now that this was  LP:1024848, which was marked fixed today in telepathy-mission-control-5 1:5.12.0-0ubuntu2.1. If somebody sees this crash again after today, follow the prompts to report the crash to Launchpad (your report will probably be automatically marked as a duplicate of some already reported bug), then reopen this ticket and link it to the Launchpad bug. Launchpad’s tools for reporting and triaging crash bugs are much better than anything we have.

Note: See TracTickets for help on using tickets.