Ticket #1203 (closed defect: fixed)

Opened 9 years ago

Last modified 8 years ago

nss_nonlocal: initgroups_dyn should return success when adding only magic groups

Reported by: andersk Owned by:
Priority: normal Milestone: The Distant Future
Component: -- Keywords:
Cc: Fixed in version: 2.1-0debathena1
Upstream bug:

Description

When the groups_nonlocal chain returns NSS_STATUS_NOTFOUND, _nss_nonlocal_initgroups_dyn also returns NSS_STATUS_NOTFOUND even though it has successfully added the magic nss-nonlocal-users group. Based on what seems to be happening on scripts (I have not yet reproduced on Debathena), I theorize that this will cause nscd to ignore the nss-nonlocal-users group for users that aren’t in any other secondary groups, and that the fix is to have _nss_nonlocal_initgroups_dyn return NSS_STATUS_SUCCESS in this case instead.

Change History

comment:2 Changed 8 years ago by andersk

  • Fixed in version set to 2.1-0debathena1

comment:3 Changed 8 years ago by andersk

  • Status changed from development to proposed

comment:4 Changed 8 years ago by jdreed

  • Status changed from proposed to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.