Ticket #1211 (new defect)

Opened 9 years ago

Last modified 9 years ago

SapGUI doesn't work on precise

Reported by: kaduk Owned by:
Priority: normal Milestone: The Distant Future
Component: -- Keywords:
Cc: Fixed in version:
Upstream bug:

Description

It complains that:

Exception in thread "main" java.lang.UnsatisfiedLinkError: /afs/athena.mit.edu/software/java_v1.4.2_03/distrib/j2sdk1.4.2_03.i386_rh9/jre/lib/i386/libawt.so: libXp.so.6: cannot open shared object file: No such file or directory

Change History

comment:1 Changed 9 years ago by kaduk

We have the 64-bit version of the library, but need the 32-bit one.

We also need: libXt and libXtst

libxp6:i386
libxt6:i386
libxtst6:i386

comment:2 Changed 9 years ago by kaduk

Hmm, though those libraries are enough to let the login panel start, attempting to connect bails with:

Error: Unable to load the GSS-API Shared Library named "/mit/sapgui/lib/libgssapi_krb5.so"

[current date]
Release 620
Component SNC (Secure Network Communication), version 5
rc = -1, module sncxxdl_mt.c, line 342
Detail SncPDLInit
System Call dlopen

comment:3 Changed 9 years ago by jweiss

Alex asked: Does anyone care any more if this runs in Athena?

I use it a few times a year.Not a lot, but enough that I find it convenient to have. I suspect that Ben actually uses it some too, and that's how he noticed ti was broken.

comment:4 Changed 9 years ago by quentin

I also use it fairly regularly. I have seen many other people use it, too.

comment:5 Changed 9 years ago by kaduk

In reply to some of the email-only traffic, it seems likely that we could get it working again by fixing the 32-bit library situation, and also some symlink farming in the locker, to match up the new sysnames.

comment:6 Changed 9 years ago by kchen

Huh, it seems that I got further on my Precise debathena-standard machine without making any manual changes. When I attempted to connect, I got (no idea why things keep getting cut off at "provi"):

[Thr 3839286080] Thu Aug 16 02:24:06 2012
[Thr 3839286080] * ERROR => SncPEstablishContext() failed for target='p:sap/zuben.mit.edu@ATHENA.MIT.EDU'

[sncxxall3445]############################# ERROR #############################

16.08. 02:24:06.204 ERROR: JniAgComAdaptor?.connect failed
############################# ERROR #############################
java.lang.Exception: Error: GSS-API(maj): Unspecified GSS failure. Minor code may provi
GSS-API(min): Program called an obsolete, deleted function
target="p:sap/zuben.mit.edu@ATHENA.MIT.EDU"

Thu Aug 16 02:24:06 2012
Release 620
Component SNC (Secure Network Communication), version 5
rc = -4, module sncxxall_mt.c, line 3411
Detail SncPEstablishContext
System Call gss_init_sec_context

[Java stacktrace here]

############################# ERROR #############################
16.08. 02:24:06.207 ERROR: GuiConnection?: Connect failed
Error: GSS-API(maj): Unspecified GSS failure. Minor code may provi
GSS-API(min): Program called an obsolete, deleted function
target="p:sap/zuben.mit.edu@ATHENA.MIT.EDU"

Thu Aug 16 02:24:06 2012
Release 620
Component SNC (Secure Network Communication), version 5
rc = -4, module sncxxall_mt.c, line 3411
Detail SncPEstablishContext
System Call gss_init_sec_context

############################# ERROR #############################

comment:7 Changed 9 years ago by ghudson

"Program called an obsolete, deleted function" suggests that the process managed to load libgssapi_krb5 and libkrb5 libraries from different versions of MIT krb5.

comment:8 Changed 9 years ago by kchen

Ah, that makes sense, since the sapgui locker has its own version of libgssapi_krb5. I got SAPGui to work by editing the startup script such that LD_LIBRARY_PATH only uses libstdc++-libc6.2-2.so.3 and libstdc++-3-libc6.2-2-2.10.0.so (but they're the same, so I don't know if they're both necessary) and not libgssapi_krb5.so.2.2, and also SNC_LIB to point to /usr/lib/i386-linux-gnu/libgssapi_krb5.so.2.

Note: See TracTickets for help on using tickets.