Ticket #1289 (new defect)

Opened 8 years ago

Last modified 8 years ago

debathena-extra-software-nox installs KDE libraries

Reported by: vasilvv Owned by:
Priority: low Milestone: Upstream Utopia
Component: -- Keywords:
Cc: Fixed in version:
Upstream bug:  LP:1115424

Description (last modified by vasilvv) (diff)

I've installed debathena-extra-software-nox on Ubuntu 12.10 (quantal), and Okular was installed (with all KDE libs) by the following way:

# aptitude why libqtcore4
i   debathena-extra-software-nox Depends    auctex                    
i A auctex                       Recommends evince | xpdf | pdf-viewer
i A okular                       Provides   pdf-viewer                
i A okular                       Depends    libqtcore4 (>= 4:4.8.0)   

Clarification: after removing Okular, apt-get autoremove deleted KDE and Qt libraries from the system.

Change History

comment:1 Changed 8 years ago by vasilvv

  • Description modified (diff)
  • Summary changed from debathena-extra-software-nox installs full set of KDE libraries to debathena-extra-software-nox installs KDE libraries

comment:2 Changed 8 years ago by jdreed

aptitude why is lying here. The real problem is that texlive-full pulls in latexmk, which has this:
{{
Recommends: xpdf-reader | pdf-viewer, gv | postscript-viewer
}}

Specifically, it's the recommendation of "pdf-viewer" that's pulling in okular. And in fact, something has changed from Precise, which, when trying to satisfy pdf-viewer, has evince-gtk has the first choice, not Okular.

comment:3 Changed 8 years ago by jdreed

  • Priority changed from normal to low
  • Upstream bug set to LP:1115424
  • Milestone changed from The Distant Future to Upstream Utopia

This only affects Server machines or other machines without ubuntu-desktop or an otherwise established desktop environment. I don't think we have a good answer here. debathena-extra-software-nox should, obviously, not depend on xpdf or anything.

Note: See TracTickets for help on using tickets.