Ticket #1336 (new defect)

Opened 8 years ago

openafs doesn't contain libkopenafs in lucid, squeeze

Reported by: achernya Owned by:
Priority: normal Milestone: Current Semester
Component: -- Keywords:
Cc: Fixed in version:
Upstream bug:

Description

The upcoming liblocker athfsck commit changes liblocker from statically linking various afs libraries, to instead dynamically linking libkopenafs.

However, lucid and squeeze have an OpenAFS that's sufficiently old that libkopenafs is not yet provided. We need to rebuild/change the packaging of OpenAFS in these two distros so that the build and runtime dependencies can be satisfied.

Bad ideas include backporting AFS 1.6 into these two; Linerva already does this for Squeeze.

Note: See TracTickets for help on using tickets.