Ticket #135 (closed defect: fixed)

Opened 13 years ago

Last modified 13 years ago

/etc/shells or chsh needs patching

Reported by: jdreed Owned by: broder
Priority: normal Milestone:
Component: Keywords:
Cc: Fixed in version:
Upstream bug:

Description

Moira's chsh uses /etc/shells to determine whether the user is trying to shoot themselves in the foot or not. We should either:

  • add /bin/athena/tcsh and /bin/athena/bash to /etc/shells (I think we can skip cruft that's in /etc/shells on Athena 9, like shells from the gnu or sipb lockers)
  • Patch chsh to use some new list (/etc/shells.moira) or something. That way we can also remove things like /sbin/nologin from the list, since on Athena 9, Moira will happily let you change your shell to that.

Change History

comment:1 Changed 13 years ago by broder

  • Owner set to broder
  • Status changed from new to accepted

Fixed in r23595; now uploaded to -proposed.

I've confirmed on one of my machines that /etc/shells is appropriately manipulated (a) when the package is installed, (b) when the package is uninstalled, (c) when the package is subsequently re-installed.

I'll move this into production in 2 days if there are no objections.

comment:2 Changed 13 years ago by broder

  • Status changed from accepted to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.