Ticket #141 (closed defect: worksforme)

Opened 13 years ago

Last modified 12 years ago

Firefox extension should update application defaults?

Reported by: broder Owned by:
Priority: low Milestone: Fall 2009 Release
Component: -- Keywords:
Cc: Fixed in version:
Upstream bug:

Description (last modified by broder) (diff)

Regardless of how the PDF reader debate plays out, there will be a particular PDF reader that Debathena prefers.

If it's not acroread, we should consider upgrading people's Firefox profile defaults when they use Debathena.

We should figure out a good way to do this - preferably one that doesn't break acroread under Athena, and also allows users to change the defaults back.

Something akin to a .generation file within the Firefox profile may be a good start here, but I'm not sure what the whole implementation would look like.

Change History

comment:1 Changed 13 years ago by broder

  • Description modified (diff)

comment:2 Changed 12 years ago by broder

  • Component set to --
  • Milestone set to Fall Release

comment:3 Changed 12 years ago by rbasch

The firefox extension has never set application defaults, even in Athena 9.4; firefox has used gnome for that for a while -- see /etc/gnome/defaults.list. Any system-wide changes should be done by modifying that file.

comment:4 Changed 12 years ago by broder

Class: debathena Instance: trac-#141
Time: Tue Aug 25 15:20:07 2009 Host: dr-wily.mit.edu
From: Evan Broder <broder>

Huh - I would have sworn that the first time I opened a PDF in Firefox
on a Debathena machine, it opened in acroread

Class: debathena Instance: trac-#141
Time: Tue Aug 25 15:22:28 2009 Host: KIKO.MIT.EDU
From: Robert Basch <rbasch>

Do you have an old profile?  We used to set acroread as the default pdf
app, back before the gnome integration (and when we built firefox from
source).

Class: debathena Instance: trac-#141
Time: Tue Aug 25 15:23:15 2009 Host: dr-wily.mit.edu
From: Evan Broder <broder>

I haven't been around for that long

Class: debathena Instance: trac-#141
Time: Tue Aug 25 15:32:54 2009 Host: KIKO.MIT.EDU
From: Robert Basch <rbasch>

Looks like the firefox extension first appeared in 9.4.27, circa summer 2006.

...

Class: debathena Instance: trac-#141
Time: Tue Aug 25 15:38:01 2009 Host: KIKO.MIT.EDU
From: Robert Basch <rbasch>

You can grep for acroread in mimeTypes.rdf, in your profile directory.
That was where our old firefox build would set it.

Class: debathena Instance: trac-#141
Time: Tue Aug 25 15:42:42 2009 Host: dr-wily.mit.edu
From: Evan Broder <broder>

Yeah, I don't see it - I've probably blown away my profile since then.
If nobody else can reproduce, the ticket should be closed as such

Class: debathena Instance: trac-#141
Time: Tue Aug 25 15:44:19 2009 Host: KIKO.MIT.EDU
From: Robert Basch <rbasch>

I do have it set in at least one of my old profiles.  Maybe we should
document how to revert to the system default.

It looks like just removing the mimeTypes.rdf file is sufficient to reset to the defaults. One issue, though, is that I can't find PDFs in Edit -> Preferences -> Applications to change the setting.

comment:5 Changed 12 years ago by rbasch

I think the PDF entry will show up in Edit -> Preferences -> Applications if your mimeTypes.rdf does include the acroread entry we used to set in Athena 9, but not otherwise. If it is there, the user can change it via the drop-down list in the Action column; the choices there should include "Use Document Viewer (default)", or "Always Ask".

Without the setting, or when "Always Ask" is set, users will have an opportunity to change from the default in the dialog that is displayed when they download a PDF file.

comment:6 Changed 12 years ago by jdreed

  • Status changed from new to closed
  • Resolution set to worksforme
Note: See TracTickets for help on using tickets.