Ticket #226 (closed task: fixed)

Opened 12 years ago

Last modified 11 years ago

Investigate state of open-vm-tools under Jaunty and determine whether to fully support them at this time

Reported by: jdreed Owned by: jdreed
Priority: low Milestone: Summer 2010 (Lucid Deploy)
Component: -- Keywords:
Cc: Fixed in version:
Upstream bug:  LP:332323  LP:362579  LP:391224

Description

This is a continuation of ATN-42, in which vmware tools (and open-vm-tools) was horribly broken under Hardy and Intrepid with recent kernels.

We believe everything except LP 332323 has been fixed in Jaunty.

We need to do the following:

  • Confirm that LP 306835 and 302226 are no longer an issue in Jaunty.
  • Test Debathena on Jaunty as a guest with open-vm-tools
  • Document what works and what doesn't, and make a determination about support.
  • Decide that anything older than Jaunty is not Fully Supported(tm) as a VMware Guest with open-vm-tools

History is available in ATN-42, which is archived at  http://web.mit.edu/jdreed/Public/ATN-42.html
for those without Jira access.

Change History

comment:1 Changed 12 years ago by broder

  • Upstream bug changed from https://bugs.launchpad.net/ubuntu/+source/open-vm-tools/+bug/332323 to LP:332323

comment:2 Changed 12 years ago by broder

  • Upstream bug changed from LP:332323 to LP:332323 LP:362579

I got bitten by  LP:362579 trying to install open-vm-tools on a 64-bit VM. Even with the patch, I couldn't get window resize -> resolution changes or mouse auto-ungrab working, so I switched to the normal VMWare Tools, which worked fine after I installed xserver-xorg-input-vmmouse.

I don't know how much we care if this all Just Works for 32-bit guests, though, which I haven't tested.

comment:3 Changed 12 years ago by broder

Apparently I wasn't getting some of the nice things I wanted because I didn't have open-vm-toolbox installed. open-vm-toolbox brings in the vmware-user daemon, which handles things like screen resizing.

Unity mode under Fusion still doesn't work with open-vm-tools, though. It looks like support for that may be included in Karmic, looking at  https://launchpad.net/ubuntu/karmic/+source/open-vm-tools/2009.03.18-154848-2.

comment:4 Changed 12 years ago by broder

  • Upstream bug changed from LP:332323 LP:362579 to LP:332323 LP:362579 LP:391224

comment:5 Changed 11 years ago by broder

FYI, open-vm-tools + open-vm-toolbox + open-vm-dkms on Lucid works great for me under VMWare Fusion for both i386 and amd64 guests.

comment:6 Changed 11 years ago by jdreed

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.