Ticket #231 (closed defect: worksforme)

Opened 12 years ago

Last modified 12 years ago

Gnucash breaks gconf configurations

Reported by: wdc Owned by: jdreed
Priority: normal Milestone: Fall 2009 Release
Component: documentation Keywords:
Cc: Fixed in version:
Upstream bug:

Description

If gnucash is started with the "Update Search Path" option, a seemingly benign default,
creates a .gconf.path which thereafter forces Athena 10 to look at Athena 9 gconf defaults
and suddenly your screen is a broken version of Athena 9 instead of the new Ubuntu setup.

Supplementary documentation on this issue:

 http://svn.gnucash.org/docs/help/first-time.html

 http://svn.gnucash.org/trac/browser/gnucash/trunk/src/gnome-utils/druid-gconf-setup.c#L90

removing .gconf.path seems unbreaks the gconf setup, and gnucash runs just fine without that file present,

The problem is that we can't seem to figure out how gnucash got it into its head that making that setup
was necessary.

Let's see if we can get an initial gnucash startup to fail again like this and understand WHY it did this.

The two commands:

rm -rf ~/gnucash

gconftool-2 --recursive-unset /apps/gnucash

clears out all the identifiable gnucash state, but does NOT provoke it into a setup dialog that asks if the Gnome Path can be set.

Change History

comment:1 Changed 12 years ago by broder

  • Component changed from -- to documentation

Has anybody reproduced this yet?

Maybe we should fix this one with documentation instead of code, especially since the symptom/fix are both straightforward.

comment:2 Changed 12 years ago by broder

Incidentally, some quick sourcediving shows that the .gconf.path file seems to be created in src/gnome-utils/druid-gconf-setup.c:druid_gconf_update_path. Not entirely sure why that triggers.

comment:3 Changed 12 years ago by jdreed

  • Owner set to jdreed
  • Status changed from new to accepted

comment:4 Changed 12 years ago by jdreed

  • Status changed from accepted to closed
  • Resolution set to worksforme

I spent a couple of hours trying to reproduce this, and I could not. I have documented it:

 http://kb.mit.edu/confluence/x/IQBS

Note: See TracTickets for help on using tickets.