Ticket #354 (closed defect: invalid)

Opened 12 years ago

Last modified 9 years ago

re-enable Compiz

Reported by: geofft Owned by:
Priority: normal Milestone: Quantal Quetzal
Component: -- Keywords: hackathon
Cc: Fixed in version:
Upstream bug:  LP:336932  Compiz:1312

Description (last modified by geofft) (diff)

We disabled Compiz, the upstream default wm, in favor of metacity because of  LP:336932. It would be nice to not have to do that.

Specifically, we should definitely cause the screen saver to actually cover your entire screen, and probably improve zwgc behavior (e.g. not make windowgrams show up in the taskbar).

There's also a report of memory leaks we should look into: see  7479 et seq.

Change History

comment:1 Changed 11 years ago by jdreed

  • Keywords hackathon added

Upstream is still sitting on this. If any enterprising person feels like source diving and coming up with a patch, it might help upstream suck less. Possibly a good hackathon project?

comment:2 Changed 11 years ago by andersk

It might also help to report it to the  upstream bug tracker, since they might not be checking LP.

comment:3 Changed 11 years ago by jdreed

  • Upstream bug changed from LP:336932 to LP:336932 Compiz:1312

comment:4 Changed 10 years ago by jdreed

debathena / compiz / broder  13:19  (Evan Broder)                            
       Apparently the screensaver popover issue might have been fixed in natty  
       while they were fixing LP: #771391. Someone should check                 

comment:5 Changed 10 years ago by geofft

  • Description modified (diff)

Actually even using compiz (+ unity-window-decorator) from natty (1:0.9.4+bzr20110415-0ubuntu) and not even natty-updates, I can't get zwgc to pop up over my screensaver.

Admittedly this test was done on a lucid cluster machine with natty added to sources.list, so. Someone should test on real-Natty but it seems likely this issue is resolved.

comment:6 Changed 10 years ago by geofft

So I tried playing around on a Natty machine with compiz and couldn't get anything to cause the memory usage to strictly increase. Since the specific allegation is that it increases over time, I'll leave it logged in overnight and see what happens.

But note that memory usage becoming a problem after you leave yourself logged in overnight is not actually a deployment blocker for the clusters...

comment:7 Changed 10 years ago by jdreed

Wobbly windows are also not needed for the clusters. At the moment, I favor the steady state of sticking with Metacity for now and seeing where we end up with Oneiric, because it'll be easier to switch the UI all at once to Unity (if we want to go that route). I know Compiz is shiny and everything, but I think the intersection of {people who explicitly want Compiz} and {people who regularly use cluster machines} is very small.

comment:8 Changed 10 years ago by geofft

The extrapolation was pretty premature. It seems to have approached steady state after about 15 minutes of not using it, and in the last 1.5 hours only leaked 20 kilobytes.

On the other hand I think my Unity left bar thing popped up over the screensaver at some point. This machine seems to have the natty release compiz, not the one from natty-updates, so maybe I'll try again with that one...

I've heard requests to turn Compiz back on depressingly often, actually. And even without shiny effects, it's presumably better-supported upstream.

comment:9 Changed 10 years ago by jdreed

  • Milestone changed from Upstream Utopia to Oneiric Support

comment:10 Changed 10 years ago by geofft

Strange stuff is afoot with gnome-screensaver. Upstream is removing it! Ubuntu is restoring it! Compiz is reimplementing it!

 https://blueprints.launchpad.net/ubuntu/+spec/desktop-o-screensaver

comment:11 Changed 9 years ago by jdreed

This is still broken. I came back after a 4 day outage to find Update Manager on top of the screensaver. Not only that, but it was on top of the screensaver unlock dialog, so I had no visual feedback when typing my password. I could not move the Update Manager window, nor use any of its buttons. After typing my password incorrectly twice, I gave up and hit "Esc" which closed the unlock dialog, and finally caused gnome-screensaver to cover up the Update Manager window.

"Yay".

comment:12 Changed 9 years ago by andersk

debathena / trac-#354 / andersk  13:16  (Anders Kaseorg)
    Can you reproduce with the recipe in the Launchpad bug (‘sleep 5;
    gedit’ and then lock the screen before the window opens)?
debathena / trac-#354 / andersk  13:17  (Anders Kaseorg)
    If not, it could be that this was partially fixed but Update Manager
    does some kind of always-on-top thing that defeats the partial fix.
    In which case we need to come up with a better reproduction recipe.
debathena / trac-#354 / jdreed  13:16  (This zephyr does not necessarily reflect the views of IS&T, MIT, its)
    No, I can't reprduce using that method.  It may well be Update Manager
    specific

comment:13 Changed 9 years ago by jdreed

For teh lulz, VMware managed to shove itself on top of gnome-screensaver too. But that clearly does its own thing when interacting with compiz, so I'm leaning towards "upstream fixed this, but some apps are too clever for their own good and are still broken"

comment:14 Changed 9 years ago by jdreed

  • Status changed from new to closed
  • Resolution set to invalid

This will get fixed for us now that Unity-2D is gone.

Note: See TracTickets for help on using tickets.