Ticket #356 (closed defect: worksforme)

Opened 12 years ago

Last modified 9 years ago

Firefox pops up extension list on startup

Reported by: geofft Owned by:
Priority: normal Milestone: Upstream Utopia
Component: -- Keywords:
Cc: Fixed in version:
Upstream bug:

Description

On some kinds of Firefox startup (I'm not sure about the pattern, although I suspect it's when your most recent log in was against a Firefox of a different version, e.g. Athena 9's, but possibly also between different distros), you get a full-screen extensions list informing you what successfully upgraded. This is kind of annoying because you generally don't care and it pops up over your browser. Can we suppress this window?

If this is only between Athena 9 and Debathena, and we don't have ideas on how to solve it, I'm okay with it being WONTFIXed, but it gets annoying when e.g. you're using a private workstation that's ahead of or behind the clusters in terms of release.

Change History

comment:1 Changed 12 years ago by ghudson

This is something non-Athena Ubuntu users live with, so it doesn't seem like great fodder for a local fix. (A fix appropriate for upstream would be fine, of course; perhaps addons could be tagged as system-managed rather than user-managed somehow.)

comment:2 Changed 12 years ago by geofft

  • Milestone set to Upstream Utopia

Upstream's discussion about the general issue is at
 https://wiki.mozilla.org/Firefox/Projects/Eradicate_Startup_Dialogs
of which we care about the first bit. We should point out to them the fact that, even if addons are compatible, you still get a dialog box informing you of the current set of addons.

It's worth noting, while we're here, that upstream also wants to make the "Firefox is already running" dialogs do something different, and possibly worth noting that they're looking into prompting for client certs or the master password differently when you have saved tabs.

comment:3 Changed 12 years ago by geofft

The comments in the associated blog post
 http://blog.mozilla.com/faaborg/2009/08/28/eradicating-start-up-dialogs/
mentions the "extensions.checkCompatibility" preference. Can we do something overly clever, e.g., having the wrapper script set that to false unless the previous Firefox version you ran wasn't sufficiently close to this one?

comment:4 Changed 10 years ago by jdreed

I don't actually think this happens anymore in FF 6, unless there's an extension that's not compatible. Anyone disagree?

comment:5 Changed 9 years ago by jdreed

  • Status changed from new to closed
  • Resolution set to worksforme

Thank you for taking the time to report this bug and helping to make Ubuntu better. We are unable to reproduce this bug.

Note: See TracTickets for help on using tickets.