Ticket #380 (closed defect: fixed)

Opened 12 years ago

Last modified 12 years ago

grenew FTBFS on releases without krb4

Reported by: broder Owned by: broder
Priority: blocker Milestone: Karmic Deploy (Canceled)
Component: -- Keywords:
Cc: Fixed in version:
Upstream bug:

Description

grenew needs to have the appropriate ifdefs added to allow it to build without krb4 support. Some earlier changes to the ATHENA_KRB4 autoconf macro should make this fairly easy - you can conditionalize on HAVE_KRB4. Once that's done, you can change ATHENA_KRB4_REQUIRED to ATHENA_KRB4 in configure.in.

For other Debathena packages with optional krb4 support, we've built all versions without krb4. However, since krb4 tickets are still needed on pre-{Karmic,Squeeze} releases for zephyr, this time we need to actually hack the packaging to pass --without-krb4 when the version of krb5 >= 1.7, and --with-krb4=$(shell krb5-config --prefix krb4) for older versions.

Change History

comment:1 Changed 12 years ago by broder

  • Status changed from new to proposed

Hopefully fixed in r24042, uploaded to proposed.

comment:2 Changed 12 years ago by broder

  • Status changed from proposed to closed
  • Resolution set to fixed

This is now in production.

Note: See TracTickets for help on using tickets.