Ticket #435 (closed defect: fixed)

Opened 12 years ago

Last modified 12 years ago

reactivate 2 regression: home directory must be world-listable

Reported by: geofft Owned by:
Priority: normal Milestone:
Component: login chroot Keywords:
Cc: Fixed in version:
Upstream bug:

Description

gkovacs reports and I confirmed with sipbtest that you can't log in to a cluster machine running reactivate 2 if your home directory is system:anyuser none:

E: Failed to change to directory ‘/afs/athena.mit.edu/user/g/k/gkovacs’: Permission denied

I haven't determined which change causes this, or even whether it's the new schroot version or just the more different way in which we're using it.

Change History

comment:1 Changed 12 years ago by geofft

  • Status changed from new to closed
  • Resolution set to fixed

Right, this is because I started using schroot -u root and root doesn't have your tokens, so it can't cd back into your homedir after chrooting. Fixed in r24165 by running those commands with / as the current directory.

Note: See TracTickets for help on using tickets.