Ticket #447 (closed defect: fixed)

Opened 12 years ago

Last modified 12 years ago

Update login session options for new gdm in karmic

Reported by: rbasch Owned by:
Priority: blocker Milestone: Karmic Deploy (Canceled)
Component: -- Keywords: karmic
Cc: Fixed in version:
Upstream bug:

Description

We will need to update our login session customizations for the new version of gdm in karmic. Needed changes include:

  1. Stop diverting /usr/share/gdm/BuiltInSessions/default.desktop, which does not exist in the new version. I believe this was only diverted to change the name (from "Run Xclient script"). "GNOME" is the new default session name.
  1. Our NOCALLS session is not displaying its blurb to the user, apparently because the message function is no longer available in the new /etc/gdm/Xsession. (It looks like we have other Xsession.d files using message).
  1. Review the new set of session options (in /usr/share/xsessions/). Stock set includes "GNOME", "Failsafe GNOME", and "xterm", and we will again add our "Login Without Customizations" here. We can remove the gnome-failsafe and xterm session files on cluster machines, to match what we do in the old version. We can consider adding another .desktop file if "GNOME" is deemed unsatisfactory.

Change History

comment:1 Changed 12 years ago by rbasch

I addressed (2) in r24200, by adding a 00debathena-message Xsession.d script which defines a message function if it is not already defined (debathena-xsession 1.11.3, uploaded to -proposed).

comment:2 Changed 12 years ago by rbasch

(1) is addressed in r24207 (debathena-gdm-config 1.18, now in -proposed).

comment:3 Changed 12 years ago by geofft

  • Status changed from new to closed
  • Resolution set to fixed

(1), (2), and (3) all work for me, and also I moved this package to production a little while back.

I will note that logging in without customizations is both slower than I'd expect and "sticky" across logins -- you have to explicitly unset it the next time you type your username at that machine, it seems. The latter sounds like a gdm rewrite regression, since old-gdm definitely used to ask you if you wanted to keep this session permanently.

comment:4 Changed 12 years ago by broder

Let's be clear here - (3) has only been "fixed" in that nocalls works (sort of). Removing the failsafe sessions requires a code change to cluster-login-config that hasn't been written yet, but we can certainly address that in #496

Note: See TracTickets for help on using tickets.