Ticket #477 (closed defect: worksforme)

Opened 12 years ago

Last modified 11 years ago

debathena-lprng cron job causes daily mail with error to be sent

Reported by: kchen Owned by: jdreed
Priority: low Milestone: Fall 2010
Component: printing Keywords:
Cc: zev Fixed in version:
Upstream bug:

Description

I get daily mail from two Debathena machines with:

/etc/cron.daily/debathena-lprng:
2010-01-06-06:28:43.020 abra Init_tempfile: bad tempdir '/var/spool/lpd/%P'

One is a jaunty machine, and one is a hardy machine. (Hmm... actually, I haven't gotten mail from the jaunty machine in half a month, but it's possible MIT is eating it. I'll focus this bug report on the hardy machine, which is still sending me mail.)

kchen@abra:~$ ls -l /etc/cron.daily/debathena-lprng
-rwxr-xr-x 1 root root 1241 2008-06-17 13:50 /etc/cron.daily/debathena-lprng

kchen@abra:~$ dpkg -l debathena-lprng*
Desired=Unknown/Install/Remove/Purge/Hold?
| Status=Not/Inst/Cfg?-files/Unpacked/Failed-cfg/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Hold/Reinst?-required/X=both-problems (Status,Err: uppercase=bad)

/ Name Version Description

+++-=============================================-=============================================-==========================================================================================================
ii debathena-lprng 3.8.28dfsg.1-1.1ubuntu2debathena5~ubuntu8.04 lpr/lpd printer spooling system
ii debathena-lprng-config 1.8~ubuntu8.04 Printing configuration for Debathena
ii debathena-lprng-no-server-config 1.3~ubuntu8.04 Remove lprng's cron job and init script

It looks like debathena-lprng-no-server-config is supposed to remove the cron job. One thing I just noticed is:

kchen@abra:~$ dpkg -S debathena-lprng-no-server-config | grep diversion
diversion by debathena-lprng-no-server-config from: /etc/cron.daily/lprng
diversion by debathena-lprng-no-server-config to: /usr/share/debathena-lprng-no-server-config/etc++cron.daily++lprng

Should /etc/cron.daily/debathena-lprng be diverted in addition to /etc/cron.daily/lprng? Or not installed? (I don't actually know what the cron job is supposed to do... I just know it sends me mail with an error every day.)

Change History

comment:1 Changed 12 years ago by broder

  • Component changed from -- to printing

debathena-lprng-no-server-config is an outdated package that pre-dates debathenifying LPRng.

These days, /etc/cron.daily/debathena-lprng should be suppressing that e-mail by means of this patch we insert as part of the debathenification process:

    # lprng's cron job generates mail to root each day if you're not
    # running a server.  Fix this problem by making the cron script
    # conditional on the existence of /etc/printcap, just as the
    # init.d script is.
    perl -ne 'print; /#.*main/ && print "[ -f /etc/printcap ] || exit 0\n";' \
      -i debian/debathena-lprng.cron.daily

Unfortunately, cupsd writes out a dummy /etc/printcap file for some reason, so I'm honestly not entirely sure how that ever worked.

Just deleting that job entirely would be the easy workaround - we'll see if we can come up with something better.

comment:2 Changed 11 years ago by jdreed

  • Milestone set to Summer 2010 (Lucid Deploy)

We should delete the job and move on.

comment:3 Changed 11 years ago by jdreed

  • Status changed from new to accepted
  • Owner set to jdreed

Fixed in r24474 and r24475. The cron job won't run if /etc/printcap contains the text "automatically generated by cupsd".

comment:4 Changed 11 years ago by broder

  • Status changed from accepted to proposed
From: root@remus.mit.edu (Cron Daemon)
To: root@remus.mit.edu
Subject: Cron <root@remus> test -x /usr/sbin/anacron || ( cd / && run-parts --report /etc/cron.daily )
Content-Type: text/plain; charset=ANSI_X3.4-1968
X-Cron-Env: <SHELL=/bin/sh>
X-Cron-Env: <PATH=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin>
X-Cron-Env: <HOME=/root>
X-Cron-Env: <LOGNAME=root>
Message-Id: <20100412105740.11F1954E647@remus.mit.edu>
Date: Mon, 12 Apr 2010 06:53:26 -0400 (EDT)

/etc/cron.daily/debathena-lprng:
grep: /etc/printcap: No such file or directory
2010-04-12-06:53:26.878 remus Read_file_list: cannot stat required or included file '//etc/lprng/lpd.perms' - No such file or directory

comment:5 Changed 11 years ago by broder

Updated to not start erroring out when the printcap file doesn't exist

comment:6 Changed 11 years ago by broder

  • Status changed from proposed to closed
  • Resolution set to fixed

This should be fixed now.

comment:7 Changed 11 years ago by zev

  • Status changed from closed to reopened
  • Cc zev added
  • Resolution fixed deleted

I actually just started seeing this problem on the 18th (running Karmic). Further, the email is actually getting sent to my MIT mail address:

Return-Path: <root@cliffjumper.mit.edu>
Received: from po12.mit.edu ([unix socket])
	by po12.mit.edu (Cyrus v2.1.5) with LMTP; Sun, 25 Apr 2010 01:19:56 -0400
X-Sieve: CMU Sieve 2.2
Received: from mit-mailsec-scanner-7.mit.edu by po12.mit.edu (8.13.6/4.7) id o3P5JupA001393; Sun, 25 Apr 2010 01:19:56 -0400 (EDT)
X-AuditID: 12074f12-b7bfaae000000a00-af-4bd3d0fb7fae
Received: from mailhub-4.mit.edu (MAILHUB-4.MIT.EDU [18.7.62.40])
	by mit-mailsec-scanner-7.mit.edu (Symantec Brightmail Gateway) with SMTP id 40.42.02560.BF0D3DB4; Sun, 25 Apr 2010 01:19:56 -0400 (EDT)
Received: from outgoing-legacy.mit.edu (OUTGOING-LEGACY.MIT.EDU [18.7.22.104])
	by mailhub-4.mit.edu (8.13.8/8.9.2) with ESMTP id o3P5Jtdp026483
	for <zev@MIT.EDU>; Sun, 25 Apr 2010 01:19:55 -0400
Received: from localhost (dhcp-18-111-118-146.dyn.mit.edu [18.111.118.146])
	)
	by outgoing-legacy.mit.edu (8.13.6/8.12.4) with ESMTP id o3P5JnH2001571
	for <zev>; Sun, 25 Apr 2010 01:19:50 -0400 (EDT)
Date: Sun, 25 Apr 2010 01:19:49 -0400 (EDT)
Message-Id: <201004250519.o3P5JnH2001571@outgoing-legacy.mit.edu>
From: Anacron <root@MIT.EDU>
To: root@MIT.EDU
Subject: Anacron job 'cron.daily' on cliffjumper
X-Brightmail-Tracker: AAAAAhPYxGwT2NmW

/etc/cron.daily/lprng:
2010-04-25-01:19:52.197 cliffjumper Init_tempfile: bad tempdir '/var/spool/lpd/%P'

comment:8 Changed 11 years ago by zev

To be clear, I've already installed the latest debathena-lprng and have only /recently/ started seeing the problem.

comment:9 Changed 11 years ago by jdreed

  • Status changed from reopened to closed
  • Resolution set to worksforme
  • Milestone changed from Summer 2010 (Lucid Deploy) to Fall 2010

I can't reproduce this, on multiple machines. If this persists, please send /etc/printcap and the output of the cron job run with -x

jdreed@infinite-loop:~$ sh -x /etc/cron.daily/debathena-lprng
+ test -x /usr/sbin/checkpc
+ test -e /etc/printcap
+ CS_WARN=Warning
+ CS_ERROR=lp\: Need to fix
+ CS_DENY=Warning|lp\: Need to fix
+ CS_LOCK_OWN=Warning - owner/group of ./var/lock. are 0/0, not 7/7
+ CS_LOCK_PERM=Warning - permissions of ./var/lock. are 041777, not 042700
+ CS_MISS_LOCKFILE=Warning - LPD Lockfile .* does not exist!
+ CS_ALLOW=Warning - owner/group of ./var/lock. are 0/0, not 7/7|Warning - permissions of ./var/lock. are 041777, not 042700|Warning - LPD Lockfile .* does not exist!
+ [ -f /etc/printcap ]
+ grep -q automatically generated by cupsd /etc/printcap
+ exit 0
}}

Note: See TracTickets for help on using tickets.