Ticket #502 (reopened enhancement)

Opened 12 years ago

Last modified 9 years ago

cups-lpq doesn't tell you where a printer is

Reported by: geofft Owned by:
Priority: insignificant Milestone: Upstream Utopia
Component: printing Keywords:
Cc: Fixed in version:
Upstream bug:

Description

dr-wily:~ geofft$ lpq -Pmassave
Printer: massave@mulch  'HP NW86-158'
 Queue: no printable jobs in queue
 Status: job 'fiona_yu@sp-res14+812' removed at 13:47:05.689
 Filter_status: done at 13:47:05.636
dr-wily:~ geofft$ lpq -Ptree-eater
tree-eater is ready
no entries

If we ever end up writing our own lpq or fixing lpstat or whatever, this would be a nice feature to bring back.

Change History

comment:1 Changed 12 years ago by jdreed

  • Milestone set to The Distant Future

The GUI gives this info, so it's probably available somehow. I'm not convinced it's useful, however. Frequently, the problem is that people in W20-575 can't find a printer, and knowing the room number won't help. The information may also be very wrong. For example:

Printer: wired@mulch  'HP5SI 11-226'
 Queue: no printable jobs in queue
 Status: removing job 'akiss@GOOD-APPLE+285' at 18:44:44.767
 Filter_status: device = 'Warming Up' at 15:24:49.498

'wired' hasn't been in 11-226 since 1996.

comment:2 Changed 11 years ago by jdreed

  • Status changed from new to closed
  • Resolution set to wontfix

Irrelevant in the Pharos world.

comment:3 Changed 11 years ago by geofft

  • Status changed from closed to reopened
  • Resolution wontfix deleted

So long as there exists an Athena print infrastructure that is not Pharos for non-cluster printers (those in DLC/student group offices, or non-release-team-owned cluster spaces like the 6.004 lab), this is still relevant.

comment:4 Changed 10 years ago by jdreed

  • Priority changed from low to insignificant

So, this is easy using just the cups module (cups.Connection().getPrinterAttributes(queuename)['printer-location']). This is hard given how debathena-printing-config is architected. I also maintain this is an upstream utopia bug, since we're asking for a feature CUPS' lpq doesn't have.

comment:5 Changed 10 years ago by jdreed

Hrm, you probably want printer-info? too, since that's what we gave LPRng

comment:6 Changed 9 years ago by jdreed

  • Milestone changed from The Distant Future to Upstream Utopia

The goal is to stop adding features to the wrappers. LPRng includes certain fields in its lpq output, CUPS does not. This is a CUPS upstream bug.

Also, the average undergrad does not know that lpq did this, and does not miss anything. Also, the average undergrad does not use lpq.

Note: See TracTickets for help on using tickets.