Ticket #60 (closed defect: fixed)

Opened 14 years ago

Last modified 13 years ago

Fix all scripts/binaries in AFS that use the wrong path for AFS/Hesiod on Debathena

Reported by: tabbott Owned by:
Priority: normal Milestone:
Component: Keywords:
Cc: wdc Fixed in version:
Upstream bug:

Description

I'd like to finish getting rid of all the instances of "/bin/athena/fs", "/bin/athena/hesinfo", and friends hardcoded in programs in AFS. This is problematic for both Debathena and Macathena, because other distributions of OpenAFS and Hesiod put these binaries in /usr.

Below is a list of all files in the whichlocker database that reference any of the affected scripts, and which ones they reference

We should generate patches for each of these to look in PATH and submit them upstream.

*slw locker:
/bin/athena/hesinfo: /mit/slw/bin/slwping

*cref locker:
/bin/athena/hesinfo: /mit/cref/bin/cable
/bin/athena/hesinfo: /mit/cref/bin/cable-sipb

*ops locker: /bin/athena/fs: /mit/ops/bin/move_volumes_dev
/bin/athena/fs: /mit/ops/bin/move_volumes
/bin/athena/vos: /mit/ops/bin/dumpsetsize

*consult locker:
/bin/athena/vos: /mit/consult/bin/afsquota
/bin/athena/fs: /mit/consult/bin/fsr
/bin/athena/vos: /mit/consult/bin/lastlog
/bin/athena/hesinfo: /mit/consult/bin/lookup
/bin/athena/vos: /mit/consult/bin/lookup
/bin/athena/fs: /mit/consult/bin/lookup
/bin/athena/hesinfo: /mit/consult/bin/whichfs

Change History

comment:1 Changed 13 years ago by wdc

  • Cc wdc added

tabbott and I reviewed the state of these scripts and they're still broken.
I'm going to poke at the locker owners and see if I can get some progress.

comment:2 Changed 13 years ago by jdreed

I thought I had updated most of the consult locker ones, but I will make another pass through them.
Looking in PATH has the problem that PATH could be wrong or unset, but I can ensure that it checks multiple locations for hesinfo,etc.

comment:3 Changed 13 years ago by jdreed

I've made another pass through the consult locker. Lastlog is in C and has bitrotted, so I'm going to rewrite it in Perl and will fix it then. I'm trying to decide why we need "whichfs" and "lookup", so I haven't dealt with those yet. fsr already looks in /usr/bin and then falls back to /bin/athena. Everything else now uses the version in $PATH. When I have more time, I'll make them explicitly check PATH and fallback to /bin/athena, right now they just bail.

The cref locker is likely going to die, so consider those marked as WONTFIX. For the slw locker, you should talk to alexp, and for ops you should talk to ops.

comment:4 Changed 13 years ago by jdreed

The consult locker is done. Everything checks $PATH as well as a few default locations, except fsr, because we're not the upstream for that, and I don't think it's worth changing it that much. fsr has a list of places it thinks "fs" should be found, which includes /usr/bin and /bin/athena. Adding other locations is trivial.

In addition, I changed most of the scripts from /usr/athena/bin/perl to "/usr/bin/env perl". This has the side effect that they won't run on platforms that don't have "env", but I don't think we have to care about those platforms anymore. (And we believe that to be only vax anyway)

comment:5 Changed 13 years ago by geofft

  • Status changed from new to closed
  • Resolution set to fixed

slwping and the consult locker are all fixed. CSS no longer uses the cable logging scripts in cref, so it doesn't much matter what they do. The scripts in the ops locker are fairly crusty -- one uses /usr/tmp -- and they don't look useful for anyone other than ops anyway, so it's not a bug for our bug tracker.

Closing.

Note: See TracTickets for help on using tickets.