Ticket #605 (closed defect: fixed)

Opened 11 years ago

Last modified 11 years ago

firefox-wrapper broken on lucid: "default" is now an awk reserved word

Reported by: geofft Owned by: rbasch
Priority: normal Milestone: Summer 2010 (Lucid Deploy)
Component: -- Keywords:
Cc: Fixed in version:
Upstream bug:

Description

If you try running Firefox on lucid while your profile is locked from another machine, you get the "Firefox is running, but not responding." dialog box instead of our dialog box indicating Firefox is in use on another computer.

On further investigation, if you run firefox at a command prompt, you see:

mary-kay-commandos:~ geofft$ firefox
awk: cmd. line:24:       default = "";
awk: cmd. line:24:       ^ syntax error
awk: cmd. line:31:             default = id;
awk: cmd. line:31:             ^ syntax error
awk: cmd. line:34:       if (use_default != 0 && default != "")
awk: cmd. line:34:                               ^ syntax error
awk: cmd. line:36:       else if (nprofiles == 1 && count == 1)
awk: cmd. line:36:       ^ syntax error

Apparently this is because as of Lucid's version of awk, default is a reserved word:

dr-wily:~ geofft$ awk --version | head -1
GNU Awk 3.1.5
dr-wily:~ geofft$ awk 'BEGIN {default=3; print default;}'
3
dr-wily:~ geofft$ awk 'BEGIN {defaul=3; print defaul;}'
3
mary-kay-commandos:~ geofft$ awk --version | head -1
GNU Awk 3.1.6
mary-kay-commandos:~ geofft$ awk 'BEGIN {default=3; print default;}'
awk: BEGIN {default=3; print default;}
awk:        ^ syntax error
awk: BEGIN {default=3; print default;}
awk:                         ^ syntax error
mary-kay-commandos:~ geofft$ awk 'BEGIN {defaul=3; print defaul;}'
3

Change History

comment:1 Changed 11 years ago by rbasch

  • Owner set to rbasch
  • Status changed from new to assigned

Confirmed; default, which can be used within a switch statement, is now reserved. I will write a patch soon to rename the variable.

comment:2 Changed 11 years ago by rbasch

  • Status changed from assigned to proposed

Fixed in r24728 (10.0.8).

comment:3 Changed 11 years ago by broder

  • Status changed from proposed to closed
  • Resolution set to fixed

Moved to production

Note: See TracTickets for help on using tickets.