Ticket #610 (closed defect: fixed)

Opened 11 years ago

Last modified 11 years ago

Fix apparmor and nsswitch interactions

Reported by: broder Owned by:
Priority: normal Milestone: Summer 2010 (Lucid Deploy)
Component: -- Keywords:
Cc: Fixed in version:
Upstream bug:

Description

debathena-nsswitch-config diverts /etc/nsswitch.conf.debathena.

/etc/apparmor.d/abstractions/nameservice in AppArmor? will presumably prevent enforcing apps from reading that file.

We should fix that.

Change History

comment:1 Changed 11 years ago by broder

  • Summary changed from Fix apparmor and nsswitch.conf.debathena interactions to Fix apparmor and nsswitch interactions

Actually, I bet the problem is at least a little more widespread than just nsswitch.conf

AppArmor? probably prevents applications from reading /etc/hesiod.conf. Which isn't really problematic behavior because all of the Hesiod defaults work for our environment, but is still a little unfortunate.

comment:2 Changed 11 years ago by broder

  • Status changed from new to proposed

Uploaded to proposed today.

comment:3 Changed 11 years ago by broder

  • Status changed from proposed to closed
  • Resolution set to fixed

Moved to production today, so this should be fixed.

Note: See TracTickets for help on using tickets.