Ticket #634 (closed defect: duplicate)

Opened 11 years ago

Last modified 10 years ago

daemon/zulu.mit.edu@MIT.EDU is not a real e-mail address

Reported by: geofft Owned by:
Priority: low Milestone: The Distant Future
Component: -- Keywords:
Cc: Fixed in version:
Upstream bug:

Description

I think the $kuser code in debathena-msmtp-config wants to do something different. I'm not sure what. Check that the tickets match a user account (or a nonlocal user account, per the logic a few lines later)? Strip the instance?

From daemon/zulu.mit.edu@MIT.EDU Sun Jun 27 02:25:11 2010
Return-path: <daemon/zulu.mit.edu@MIT.EDU>
Envelope-to: geofft@water-buffalo.mit.edu
Delivery-date: Sun, 27 Jun 2010 02:25:11 -0400
Received: from mailhub-auth-2.mit.edu ([18.7.62.36])
        by water-buffalo.mit.edu with esmtp (Exim 4.67)
        (envelope-from <daemon/zulu.mit.edu@MIT.EDU>)
        id 1OSlIl-0007gM-Hk
        for geofft@water-buffalo.mit.edu; Sun, 27 Jun 2010 02:25:11 -0400

Change History

comment:1 Changed 11 years ago by broder

How is the right fix not something like this:

Index: debian/debathena-msmtp
===================================================================
--- debian/debathena-msmtp	(revision 24762)
+++ debian/debathena-msmtp	(working copy)
@@ -40,7 +40,7 @@
 
 sub from_address {
   # If we have tickets, use them
-  if ($kuser) {
+  if ($kuser && $kuser !~ m/\//) {
     return "--from=" . join('@', $kuser, 'mit.edu');
   }
   # Note that ATHENA_USER is explicitly not checked here. We've

We already know that $kuser is a valid Kerberos principal, and I think we can safely say that any principal with a null instance counts as a user who can send and receive mail, so all we need to do is check for an instance.

comment:2 Changed 10 years ago by jdreed

  • Status changed from new to closed
  • Resolution set to duplicate

Dupe of #806

Note: See TracTickets for help on using tickets.