Ticket #714 (closed defect: wontfix)

Opened 11 years ago

Last modified 9 years ago

webmail.mit.edu and Firefox warn-on-redirect don't work well

Reported by: geofft Owned by:
Priority: insignificant Milestone: The Distant Future
Component: upstream Keywords:
Cc: Fixed in version:
Upstream bug:

Description

There's a somewhat-questionable feature in Firefox in preferences, "Warn me when websites try to redirect or reload the page". Apparently if you enable this and try to log in to webmail, you don't get warned at all on redirect.php, but you just get a blank page. Reloading gets you the "expected" warning that you can click on to permit the redirect.

I haven't debugged this in any detail, but my naïve suspicion is that the remember-your-password prompt, that uses the same warning mechanism (a little bar at the top of the client area with a button on the right), is preventing display of the okay-to-redirect prompt.

Change History

comment:1 Changed 10 years ago by jdreed

This feature is mostly ineffective, because it doesn't catch <meta http-equiv="REFRESH" ...>. It only catches JavaScript? redirects, and does so poorly. And it's not the save password thing, because FF6 displays that differently, and it's still broken in FF6. I'm tempted to WONTFIX this.

comment:2 Changed 10 years ago by jdreed

  • Milestone set to The Distant Future

comment:3 Changed 9 years ago by jdreed

  • Status changed from new to closed
  • Resolution set to wontfix

If someone finds a website other than webmail.mit.edu where this breaks, reproducible with modern FF, re-open it, but the Cyrus retirement effort has begun.

Note: See TracTickets for help on using tickets.