Ticket #812 (closed defect: fixed)

Opened 11 years ago

Last modified 10 years ago

gdm applets steal focus from login window

Reported by: jdreed Owned by:
Priority: low Milestone: Natty Beta
Component: -- Keywords:
Cc: Fixed in version:
Upstream bug:

Description

It's not possible to hit "Enter" and simply log in, because some of our gdm applets are stealing focus.

(I thought we already had a ticket for this).

Change History

comment:1 Changed 11 years ago by jdreed

  • Status changed from new to committed

comment:2 Changed 10 years ago by jdreed

  • Status changed from committed to new

r24979 didn't actually fix this.

comment:3 Changed 10 years ago by jdreed

OK, this makes nose sense. Short of handling focus events manually, anyone have a better idea?

comment:4 Changed 10 years ago by jdreed

Hrm. I suspect the issue is that the windows should be popup, not toplevel windows. That won't fix kiosk, though, which is a toplevel. One app can't hand focus off to another, can it?

comment:5 Changed 10 years ago by jdreed

  • Status changed from new to committed

OK, setting can_focus is insufficient. We also need to unset accept_focus and focus_on_map. Committed in r25221. The diff sucks because glade insists on scribbling over the file. I've marked this as 1.29 unreleased, because I'd like to punt glade entirely, I think. But for now, this works.

comment:6 Changed 10 years ago by jdreed

  • Status changed from committed to development

comment:7 Changed 10 years ago by jdreed

  • Status changed from development to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.