Ticket #844 (closed defect: fixed)

Opened 11 years ago

Last modified 11 years ago

YouTube causes 755s to crash hard, and 745s to look funny

Reported by: geofft Owned by:
Priority: high Milestone: The Distant Future
Component: -- Keywords:
Cc: Fixed in version:
Upstream bug:

Description

A user reported that cluster computers would crash after a minute or two of watching a YouTube? video. We reproduced this on his account on opus, which is an OptiPlex? 755 running 10.04.2 debathena-workstation i686: the screen goes blank and the machine no longer pings.

Change History

comment:1 Changed 11 years ago by geofft

Jon and I can reproduce, although it's not immediate and may require some clicking around to trigger. Thanks to the magic of  netconsole, I have a backtrace from opus:

[  837.584013] [drm:radeon_fence_wait] *ERROR* fence(f6861be0:0x00000EE1) 508ms timeout going to reset GPU
[  837.584021] radeon 0000:01:00.0: GPU softreset 
[  837.584025] radeon 0000:01:00.0:   R_008010_GRBM_STATUS=0xE53024E0
[  837.584029] radeon 0000:01:00.0:   R_008014_GRBM_STATUS2=0x00110003
[  837.584033] radeon 0000:01:00.0:   R_000E50_SRBM_STATUS=0x200000C0
[  837.584042] radeon 0000:01:00.0:   R_008020_GRBM_SOFT_RESET=0x00007FEE
[  837.584096] radeon 0000:01:00.0: R_008020_GRBM_SOFT_RESET=0x00000001
[  837.584154] radeon 0000:01:00.0:   R_000E60_SRBM_SOFT_RESET=0x00000402

comment:2 Changed 11 years ago by jdreed

This bug manifests itself differently on 745s (RV516 cards), in that YouTube? works, but the video is purple tinted and there's some ghosting.

I cannot reproduce on a 760. Other people should test 760s and 780s please.

This seems to be very specifically YouTube?'s fault, in that TechTV works just fine, as does Hulu.

comment:3 Changed 11 years ago by jdreed

Interestingly enough, videos which require an ad first on youtube work just fine right up until the video itself is loaded. (The ad displays fine).

comment:4 Changed 11 years ago by jdreed

  • Summary changed from YouTube causes cluster hardware to crash hard to YouTube causes 755s to crash hard, and 745s to look funny

comment:5 Changed 11 years ago by jdreed

This is entirely Flash's fault. Downgrading to 10.0.45.2 results in normal behavior.

comment:6 Changed 11 years ago by jdreed

Bob points us to  http://ubuntuforums.org/showthread.php?p=10519535 and  http://www.webupd8.org/2011/03/fix-pinkred-youtube-videos-bug-using.html however the /etc/adobe/mms.cfg method documented there did not appear to work for me (the "hardware acceleration" checkbox was still checked, even after clearing various caches).

comment:7 Changed 11 years ago by rbasch

 LP:729307 seems relevant, and the Adobe bug  https://bugs.adobe.com/jira/browse/FP-6327.

I think the suggestion of disabling OverrideGPUValidation in /etc/adobe/mms.cfg won't work generally, as that option (as the name suggests) only bypasses Flash's check of the card/driver before enabling acceleration. I don't see any way of disabling acceleration via mms.cfg.

comment:8 Changed 11 years ago by kaduk

We had a user trigger this in m66-080 (hardware appears to be a 780 from remote reports), reportedly losing three hours of work on a paper.
Do we want to pull back to an older flash?

comment:9 Changed 11 years ago by kaduk

Upstream has pushed flash 10.2.153, and with flashplugin-nonfree-10.2.153.1ubuntu0.10.04.1 installed on opus.mit.edu, I could not produce the crash.

(We can probably pull the gmotd?)

comment:10 Changed 11 years ago by jdreed

  • Status changed from new to closed
  • Resolution set to fixed

with flashplugin-nonfree-10.2.153.1ubuntu0.10.04.1 installed on opus.mit.edu, I could not produce the crash.

Confirmed. I'll ask Ops to pull the motd.

Note: See TracTickets for help on using tickets.