Ticket #893 (closed defect: worksforme)

Opened 10 years ago

Last modified 10 years ago

CUPS is now unwilling to have no default printer

Reported by: geofft Owned by:
Priority: normal Milestone: Upstream Utopia
Component: -- Keywords:
Cc: Fixed in version:
Upstream bug:

Description

On linerva (CUPS 1.3.8):

>>> import cups
>>> cups.Connection().getDefault()
>>> 

On tyger (CUPS 1.4.4):

>>> import cups
>>> cups.Connection().getDefault()
'Adobe_PDF_7_0'
>>>

I think this is also true of Maverick/Natty?. This breaks our code that tells you to go set a default printer, and makes lpr with no -P argument instead go to some random untrusted printer, which is a bit of a problem.

(Alternatively, it's entirely possible CUPS 1.3.x does this, and linerva simply isn't on a subnet where anyone else is broadcasting printers.)
We should debug and report this regression upstream, and then figure out if we care to work around it locally.

Change History

comment:1 Changed 10 years ago by jdreed

One wonders what happens if browsing is entirely disabled.

Also, as I've said before, the right thing to do here is to give up on BrowsePolling? against printers.mit.edu, and simply ship a single printer entry for Pharos for all versions of Debathena. Users of -workstation and lower can then add whatever local printers they want, by hand, since that's how it works on every other OS. We can add code in the postinst to set "mitprint" as the default printer unless the user had already set a default. Certainly, I think "lpr" with no arguments should end up at a Pharos queue, unless the user had previously set a default printer.

comment:2 Changed 10 years ago by jdreed

I think we just proved this isn't true. Or at least, isn't true without BrowsePolling? enabled.

comment:3 Changed 10 years ago by jdreed

  • Status changed from new to closed
  • Resolution set to worksforme
Note: See TracTickets for help on using tickets.