Ticket #935 (closed defect: fixed)

Opened 10 years ago

Last modified 10 years ago

backports listed in both sources.list and sources.list.d

Reported by: geofft Owned by: jdreed
Priority: normal Milestone: The Distant Future
Component: -- Keywords:
Cc: Fixed in version:
Upstream bug:

Description

On w20-575-1 and -2, backports is uncommented in /etc/apt/sources.list, and also provided by cluster-login-config in /etc/apt/sources.list/debathena-backports.list. I'm not sure what caused the former. Guess 1 is that someone was testing on these machines and didn't clean up. Guess 2 is that some Ubuntu tool noticed backports is enabled and automatically uncommented the lines from /etc/apt/sources.list for some reason. Neither really seems plausible, though.

Change History

comment:1 Changed 10 years ago by jdreed

"I bet I know what causes this:"

pxe/lucid/debathena/preseed.autoinstall:d-i apt-setup/backports boolean true

We've apparently been enabling backports since forever when using the PXE installer?

comment:2 Changed 10 years ago by jdreed

  • Status changed from new to accepted
  • Owner set to jdreed

It's unclear whether the right answer is to let the PXE installer keep doing that (Did we know we were doing that? Was it by design? We've been doing it since intrepid.) or to pretend that we never want -backports, and let c-l-c or thirdparty or whatever deal.

comment:3 Changed 10 years ago by jdreed

Now would be a good time to turn off backports, if we're going to. Anyone want to argue for one way or the other?

comment:4 Changed 10 years ago by kaduk

amb mentioned that this was probably for radeon (or radeonhd?) configuration on the 755s, if I remember correctly. Something about ATN:17, too?
We could probably get rid of backports, then, at this point.

comment:5 Changed 10 years ago by jdreed

  • Status changed from accepted to closed
  • Resolution set to fixed

comment:6 Changed 10 years ago by jdreed

Note: See TracTickets for help on using tickets.