Ticket #951 (closed enhancement: fixed)

Opened 10 years ago

Last modified 9 years ago

add-athena-printer should use hpijs or prompt for drivers

Reported by: jdreed Owned by:
Priority: normal Milestone: Precise Release
Component: -- Keywords:
Cc: Fixed in version: debathena-printing-config 1.29
Upstream bug:

Description

add-athena-printer copying the print server's idea of a PPD/driver is probably the wrong answer until we get hpijs. Especially for the 9050s, since HP seems determined to break PostScript?. add-athena-printer should have a list of preferred hpijs drivers (in this case, pcl ones) for the hardware types we support, and prompt otherwise. (Or guess, and then whine at the user to go double-check it in s-c-p)

Change History

comment:1 Changed 9 years ago by jdreed

add-athena-printer's verbositiy increased in r25616/1.29 (UNRELEASED). I think attempting to do anything programmatically with drivers will just make everyone sad.

comment:2 Changed 9 years ago by jdreed

  • Status changed from new to committed

comment:3 Changed 9 years ago by jdreed

  • Status changed from committed to development

1.29 in -dev.

comment:4 Changed 9 years ago by jdreed

  • Status changed from development to proposed
  • Fixed in version set to debathena-printing-config 1.29

comment:5 Changed 9 years ago by jdreed

  • Status changed from proposed to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.