Ticket #978 (closed task: fixed)

Opened 10 years ago

Last modified 10 years ago

Possible installation hang with lvremove

Reported by: geofft Owned by:
Priority: normal Milestone: Natty Release
Component: -- Keywords:
Cc: Fixed in version:
Upstream bug:

Description

I ran into the lvremove -f /dev/athena/keep_2 from install-debathena.sh hanging on lola-granola. I was attempting to reinstall it after an abortive previous install. We should see if this is reproducible when installing on a machine that has already been partially (or wholly) installed.

Here's the debugging info I got:

   debathena / personal / geofft  17:23  (Geoffrey Thomas)
       .... ... .. why is `lvremove -f /dev/athena/keep_2` hanging in
       sys_semtimedop?
   debathena / personal / geofft  17:24  (Geoffrey Thomas)
       with no other threads?
   debathena / personal / geofft  17:57  (Geoffrey Thomas)
       According to gdb, we're in semop in dm_udev_wait in ?? in
       lv_deactivate in ?? in ?? in lock_vol in lv_remove_single
   debathena / personal / geofft  18:12  (Geoffrey Thomas)
       Also at about the same time I got
       udevd-work[18528]: inotify_add_watch(6, /dev/dm-2, 10) failed: No such
       file or directory
   debathena / personal / geofft  18:12  (Geoffrey Thomas)
       And strace says
       semop(0, {{0, 0, 0}}, 1

If we can't reproduce this and don't see this again, this ticket should be closed.

Change History

comment:1 Changed 10 years ago by jdreed

  • Status changed from new to closed
  • Resolution set to fixed

This was fixed and pushed to production, in that we no longer create that partition and thus don't need to remove it.

Note: See TracTickets for help on using tickets.