source: trunk/debathena/config/gconf2-config/debian/rules @ 24493

Revision 24493, 938 bytes checked in by broder, 14 years ago (diff)
In gconf2-config: * Configure gconf through /usr/share/gconf/default.path instead of /etc/gconf/2/path, as it makes ucf less likely to do dumb things. (Trac: #247)
  • Property svn:executable set to *
RevLine 
[22685]1#!/usr/bin/make -f
2
[22863]3DEB_DIVERT_EXTENSION = .debathena
[22922]4DEB_TRANSFORM_FILES_debathena-gconf2-config += \
[24493]5        /usr/share/gconf/default.path.debathena
6
7DEB_UNDIVERT_FILES_debathena-gconf2-config += \
[22863]8        /etc/gconf/2/path.debathena
[24493]9DEB_UNDIVERT_VERSION_/etc/gconf/2/path.debathena = 1.7~
10
[22863]11include /usr/share/cdbs/1/rules/debhelper.mk
[22922]12include /usr/share/cdbs/1/rules/config-package.mk
[22685]13
[22863]14GCONF_FILES = debian/gconf.afs debian/gconf.local debian/gconf.
[22685]15
[22863]16common-build-indep:: $(GCONF_FILES)
17
[22685]18DISTRO = $(shell lsb_release --short --id)
19SUFFIX = $(SUFFIX-$(DISTRO))
20SUFFIX-Debian = -debathena
21SUFFIX-Ubuntu = -debathena-ubuntu
[23286]22RELEASE = $(shell lsb_release --short --codename)
[22685]23
24ifeq ($(SUFFIX),)
25        $(error Unknown distro $(DISTRO).)
26endif
27
28debian/gconf.afs:
[23286]29        echo 'xml:readwrite:$$(HOME)/.gconf-debathena-$(RELEASE)' > $@
[22685]30
31debian/gconf.local:
32        echo 'xml:readwrite:$$(HOME)/.gconf' > $@
33
34debian/gconf.:
35        ln -sf gconf.local $@
36
37clean::
[22863]38        rm -f $(GCONF_FILES)
Note: See TracBrowser for help on using the repository browser.