source: trunk/debathena/config/gconf2-config/debian/rules @ 24493

Revision 24493, 938 bytes checked in by broder, 14 years ago (diff)
In gconf2-config: * Configure gconf through /usr/share/gconf/default.path instead of /etc/gconf/2/path, as it makes ucf less likely to do dumb things. (Trac: #247)
  • Property svn:executable set to *
Line 
1#!/usr/bin/make -f
2
3DEB_DIVERT_EXTENSION = .debathena
4DEB_TRANSFORM_FILES_debathena-gconf2-config += \
5        /usr/share/gconf/default.path.debathena
6
7DEB_UNDIVERT_FILES_debathena-gconf2-config += \
8        /etc/gconf/2/path.debathena
9DEB_UNDIVERT_VERSION_/etc/gconf/2/path.debathena = 1.7~
10
11include /usr/share/cdbs/1/rules/debhelper.mk
12include /usr/share/cdbs/1/rules/config-package.mk
13
14GCONF_FILES = debian/gconf.afs debian/gconf.local debian/gconf.
15
16common-build-indep:: $(GCONF_FILES)
17
18DISTRO = $(shell lsb_release --short --id)
19SUFFIX = $(SUFFIX-$(DISTRO))
20SUFFIX-Debian = -debathena
21SUFFIX-Ubuntu = -debathena-ubuntu
22RELEASE = $(shell lsb_release --short --codename)
23
24ifeq ($(SUFFIX),)
25        $(error Unknown distro $(DISTRO).)
26endif
27
28debian/gconf.afs:
29        echo 'xml:readwrite:$$(HOME)/.gconf-debathena-$(RELEASE)' > $@
30
31debian/gconf.local:
32        echo 'xml:readwrite:$$(HOME)/.gconf' > $@
33
34debian/gconf.:
35        ln -sf gconf.local $@
36
37clean::
38        rm -f $(GCONF_FILES)
Note: See TracBrowser for help on using the repository browser.