source: trunk/debathena/config/reactivate/debian/rules @ 25536

Revision 25536, 909 bytes checked in by jdreed, 12 years ago (diff)
In reactivate: * Set NSS_NONLOCAL_IGNORE when running getent, because we care about local gruops, not Hesiod ones * Add the user to "sudo" as well, since "admin" is gone in Precise (LP: 893842) * Use SESSION_ID, not CHROOT_NAME in schroot setup script. SESSION_ID was always right, and CHROOT_NAME simply happened to match it due to a bug (Debian: 623828) * Also divert lightdm-session (lightdm's session wrapper) and wrap it in snapshot-run
  • Property svn:executable set to *
Line 
1#!/usr/bin/make -f
2
3DEB_DIVERT_EXTENSION = .debathena
4DEB_DIVERT_FILES_debathena-reactivate += \
5        /etc/gdm/Xsession.debathena \
6        /usr/sbin/lightdm-session.debathena
7DEB_TRANSFORM_FILES_debathena-reactivate += \
8        /etc/pam.d/su.debathena \
9        /etc/default/schroot.debathena \
10        /etc/pam.d/schroot.debathena \
11        /etc/dbus-1/system.conf.debathena
12DEB_REMOVE_FILES_debathena-reactivate += \
13        /etc/xdg/autostart/jockey-gtk.desktop \
14        /etc/xdg/autostart/update-notifier.desktop \
15        /etc/xdg/autostart/nm-applet.desktop
16
17DEB_UNDIVERT_FILES_debathena-reactivate += \
18        /etc/pam.d/sudo.debathena
19DEB_UNDIVERT_VERSION_/etc/pam.d/sudo.debathena = 1.25.2~
20
21DEB_TRANSFORM_SCRIPT_/etc/default/schroot.debathena = \
22        debian/transform_schroot_defaults
23DEB_TRANSFORM_SCRIPT_/etc/pam.d/schroot.debathena = \
24        debian/transform_schroot_pam
25
26include /usr/share/cdbs/1/rules/debhelper.mk
27include /usr/share/cdbs/1/rules/config-package.mk
Note: See TracBrowser for help on using the repository browser.