Ticket #1238 (closed defect: fixed)

Opened 9 years ago

Last modified 7 years ago

Support for Unity and Upstart user sessions

Reported by: jdreed Owned by:
Priority: blocker Milestone: Current Semester
Component: -- Keywords:
Cc: Fixed in version:
Upstream bug:

Description

And you can't use any other window manager, because regular unity is implemented as a compiz plugin. We need to test Quantal on all current cluster hardware and come up with a plan for this. At the moment, it's basically unusable on VMware, which severly hampers my testing.

Change History

comment:1 Changed 9 years ago by jdreed

I don't necessarily want us to ship our own unity-2d, but I'd like us to maybe come up with some sort of fail-safe session. I don't relish the idea of the entire UI being dependent on OpenGL being functional.

comment:2 Changed 9 years ago by geofft

The plan is to make regular Unity use llvmpipe, but that will happen later in the 12.10 cycle. See  the ubuntu-devel thread "Unity Going Forward", specifically

Is it correct that at the moment a machine that will not run 2d will
not run at all after todays update? This seems to be the case for me
at the moment, I see no unity shell on screen and in .xsession-errors
I see
compiz (unityshell) - Error: OpenGL 1.4+ not supported

When can I expect llvmpipe to start working so I know whether to log bugs?

The rought ETA is sometime just after FF, so adding some time for testing
and shakeout, it might be closer to beta1.

Regarding your VMware issues, people mention success with Fusion in the thread, and in any case, VMware Player 5 / Fusion 5 / Workstation 9 came out today, and its features include improved 3D graphics support and software 3D rendering.

comment:3 Changed 9 years ago by jdreed

According to the upstream bug ( LP:927168) that my apport got marked a duplicate of, LLVMpipe is enabled now?

comment:4 Changed 9 years ago by jdreed

As of the latest round of updates, it's definitely better, and if Compiz crashes, it manages to restart itself and I at least get a usable Launcher, but it's still pretty terrible. I'm optimistic that things will get better by 'R', and fortunately we're not deploying Quantal to the clusters.

comment:5 Changed 8 years ago by jdreed

  • Summary changed from unity-2d is gone in Quantal to unity-2d is gone as of Quantal
  • Milestone changed from Current Semester to Raring Ringtail

comment:6 Changed 7 years ago by jdreed

12.04.3 works out of the box on all current cluster hardware, so this is a non-issue, I think. We may want to test what happens to people who have a .dmrc specifying a unity-2d session on, say, raring.

comment:7 Changed 7 years ago by jdreed

  • Summary changed from unity-2d is gone as of Quantal to Support for Unity and Upstart user sessions

achernya did some investigative work on this. The key changes are:

  • modify /etc/upstart-xsessions to include "athena"
  • create ~/.cache/upstart in the dbus user session, and possibly set some variable (XDG_CACHE_mumble) somewhere.
  • move 99upstart to 97 (since it clobbers $STARTUP) and handle the "athena" session name.

Some other things we should consider:

  • clean up our /etc/X11/Xsession.d stuff -- in particular, nocalls can die (to be replaced by debathena-fix-my-account which does not exist yet), and all the sanity checks should be rolled into a single thing.

It's also possible that athena-initial-xterminal will need to move or be copied into /usr/share/upstart/xdg/autostart, since I can't get it to work in the traditional location.

comment:8 Changed 7 years ago by jdreed

  • Status changed from new to review

I managed to do this without diversions or moving things, which I think is cleaner.

 https://github.com/mit-athena/xsession/pull/2

comment:9 Changed 7 years ago by jdreed

  • Status changed from review to development

comment:10 Changed 7 years ago by jdreed

  • Status changed from development to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.