Ticket #306 (closed defect: worksforme)

Opened 12 years ago

Last modified 12 years ago

Installing on the 755s hangs after downloading the stock ubuntu packages

Reported by: jdreed Owned by:
Priority: blocker Milestone: Fall 2009 Release
Component: -- Keywords:
Cc: Fixed in version:
Upstream bug:

Description

When we install on the 755s (via PXE or hackboot), we see the following weird behavior:

The install progresses normally up to the step of downloading the packages. At 99% complete, the process hangs indefinitely. ps shows two aptitude http processes sitting there. Geofft did some debugging and it appears that the processes are blocking on each other.

amb and alexp were able to reproduce.

We have no idea why this is hardware dependent.

We should also see if this affects 745s and 760s.

Change History

comment:1 Changed 12 years ago by jdreed

Attempting to kill one of the http processes cause the installer to bail, however it comes up with a fully functional stock Ubuntu system afterwards. "aptitude install debathena-cluster" seems to get it to a cluster config, but I'd prefer not to deploy until this actually works.

comment:2 Changed 12 years ago by amb

In the past, 745s installed fine.

Today, I have tested a 760 and it works, but since testing on 755s also works today (on the same hardware in the W92 test cluster that has reliably hung until now) this is not very useful information.

Can anyone still reproduce it?

comment:3 Changed 12 years ago by jdreed

I just successfully installed a 755, so... yeah. Repository issues perhaps?

How easy would it be to throw something in the installer which would allow a user to select an alternative Ubuntu mirror? If something wacky like this happens again, I'd love to be able to rule out repository weirdness without introducing too many other variables.

comment:4 Changed 12 years ago by amb

This functionality (repo selection) is now in the network installer with the undocumented menu option "1a". If we don't see it again for a while, though, I'm happy to have it closed as "worksforme".

comment:5 Changed 12 years ago by jdreed

  • Status changed from new to closed
  • Resolution set to worksforme
Note: See TracTickets for help on using tickets.