Ticket #515 (closed task: fixed)

Opened 12 years ago

Last modified 11 years ago

tweak thirdparty dependencies for lucid and amd64

Reported by: geofft Owned by: jdreed
Priority: blocker Milestone: Summer 2010 (Lucid Deploy)
Component: -- Keywords: karmic
Cc: Fixed in version:
Upstream bug:

Description (last modified by jdreed) (diff)

thirdparty was tweaked for Karmic i386. We should verify installability and fix for Lucid and amd64.

Change History

comment:1 Changed 12 years ago by geofft

  • Status changed from new to assigned
  • Owner set to jdreed

Jon said he'd do this. This basically involves trying to install thirdparty on karmic, fixing the first failure, and looping until it works.

comment:2 Changed 12 years ago by jdreed

  • Status changed from assigned to accepted

Fixed in r24369. Testing in -proposed is essential to ensure we don't break Jaunty machines

comment:3 Changed 12 years ago by jdreed

  • Status changed from accepted to proposed

Feedback on whether this causes machines to explode (or, say, try to uninstall one of the metapackages) would be particularly helpful.

comment:4 Changed 12 years ago by jdreed

  • Status changed from proposed to assigned
  • Description modified (diff)
  • Summary changed from tweak thirdparty dependencies for karmic to tweak thirdparty dependencies for lucid and amd64

comment:5 Changed 12 years ago by jdreed

For docuemntation completness, xemacs21 barfed with the following, but then "aptitude install" made it happy. I can't reproduce, and neither can others, so filing an upstream bug may be difficult.

install/elserv: Handling xemacs21, logged in /tmp/elc_aOUQRn.log
While compiling elserv-make-header in file /usr/share/xemacs21/site-lisp/elserv/elserv.el:
  ** variable system-time-locale bound but not referenced
While compiling elserv-log:
  ** variable system-time-locale bound but not referenced
While compiling elserv-autoindex-get-attr in file /usr/share/xemacs21/site-lisp/elserv/elserv-autoindex.el:
  ** variable system-time-locale bound but not referenced
While compiling the end of the data in file /usr/share/xemacs21/site-lisp/elserv/es-demo.el:
  ** The following functions are not known to be defined: 
While compiling xml-rpc-request in file /usr/share/xemacs21/site-lisp/elserv/xml-rpc.el:
  ** reference to free variable url-request-extra-headers
  ** assignment to free variable url-be-asynchronous
  ** assignment to free variable url-current-callback-data
  ** assignment to free variable url-current-callback-func
  ** reference to free variable url-be-asynchronous
  ** variable url-request-method bound but not referenced
  ** variable url-package-name bound but not referenced
  ** variable url-package-version bound but not referenced
  ** variable url-request-data bound but not referenced
  ** variable url-request-extra-headers bound but not referenced
While compiling xml-rpc-request-process-buffer:
  ** reference to free variable url-current-mime-headers
install/elserv: Deleting /tmp/elc_aOUQRn.log
install/devscripts-el: Handling xemacs21, logged in /tmp/elc_OgU3gd.log
install/devscripts-el: Deleting /tmp/elc_OgU3gd.log

Setting up debathena-thirdparty-text (0.4) ...
Processing triggers for libc-bin ...
ldconfig deferred processing now taking place
Processing triggers for menu ...
Errors were encountered while processing:
 xemacs21
E: Sub-process /usr/bin/dpkg returned an error code (1)

comment:6 Changed 11 years ago by amb

  • Status changed from assigned to proposed

xemacs21 was barfing on ocaml-mode.

Upstream:  https://bugs.launchpad.net/ubuntu/+source/ocaml/+bug/464587

I've taken ocaml-mode out of thirdparty-languages.

comment:7 Changed 11 years ago by jdreed

  • Status changed from proposed to closed
  • Resolution set to fixed

comment:8 Changed 11 years ago by jdreed

Upstream ( LP:464587) has apparently decided that the way to fix this is to Conflict: xemacs21

So we probably made the right decision, however, this means you can't get ocaml-mode on a cluster machine. It could be that nobody cares, but maybe we should either document this or pull xemacs?

Or something else?

comment:9 Changed 11 years ago by alexp

xemacs is a requirement for Allegro Common Lisp.

Note: See TracTickets for help on using tickets.