Ticket #670 (closed defect: wontfix)

Opened 11 years ago

Last modified 9 years ago

CUPS 1.3 clients can't get queue state from CUPS 1.4 servers

Reported by: geofft Owned by:
Priority: normal Milestone: Upstream Utopia
Component: -- Keywords:
Cc: Fixed in version:
Upstream bug:  CUPS:3619

Description

This is a continuation of ticket #652, which we worked around locally by detecting pre-1.4 clients and falling back to an implementation of RFC-1179 lpq in five lines of Python.

We've opened  ticket #3619 in CUPS' bugtracker about this issue. They recommended trying a newer version of the 1.3.x branch, but that did not work for me. We should track down what's different between the lpq implementations in 1.3 and 1.4.

I'll note that although lpstat seemed to work for Jon, it does not for me (on Linerva, with cups-bsd 1.3.8-1+lenny8). Perhaps something is wrong with my syntax, but...

dr-wily:~ geofft$ lpstat -h get-print acantha
lpstat: No printer-uri in request!
dr-wily:~ geofft$ lpstat -h get-print -p acantha
printer acantha now printing acantha-0.  enabled since Sat 14 Aug 2010 04:01:44 PM EDT
        Connecting to printer...
contents-vnder-pressvre:~ geofft$ lpstat -h get-print acantha
w84prt-451473           [...]          12972032   Fri 13 Aug 2010 04:27:50 PM EDT
w84prt-451474           [...]          12958720   Fri 13 Aug 2010 04:27:58 PM EDT
w84prt-451475           [...]          17232896   Fri 13 Aug 2010 04:28:05 PM EDT
acantha-451500          [...]           997376   Fri 13 Aug 2010 05:31:04 PM EDT
contents-vnder-pressvre:~ geofft$ lpstat -h get-print -p acantha
printer acantha now printing acantha-0.  enabled since Sat 14 Aug 2010 04:01:44 PM EDT
        Connecting to printer...

(cvp has cups-bsd 1.4.3-1ubuntu1.2.) Should I expect something after "Connecting to printer..."?

Change History

comment:1 Changed 11 years ago by andersk

Michael Sweet responds on  CUPS:3619:

“Geoffrey,

I know it has been a while, but if you can still reproduce this please
send me a debug error_log file from the server so I can see what is going
wrong.

Thanks!

and just so it is clear, I am unable to reproduce your problem going from
1.3.11 to 1.4.6 or current 1.5svn...”

comment:2 Changed 11 years ago by andersk

Michael Sweet responds on  CUPS:3619:

“This STR has not been updated by the submitter for two or more weeks and has been closed as required by the CUPS Configuration Management Plan. If the issue still requires resolution, please re-submit a new STR.”

comment:3 Changed 11 years ago by andersk

I did a bisect on CUPS svn to figure out where the client first starts working against current servers:

 r8927 | mike | 2009-12-15 17:09:02 -0500 (Tue, 15 Dec 2009) | 3 lines

IPP conformance: Get-Jobs has a default value for requested-attributes ( STR #3383)

comment:4 Changed 10 years ago by jdreed

So, this only affects Lenny and Hardy at this point, right? Do we plan to do the necessary work to get SRUs? Frankly, I'm fine with printing-config's hack (and printing-config can't go away as long as we have private queues behind an F5). We should either close this ticket or move to Upstream Utopia.

comment:5 Changed 9 years ago by jdreed

  • Milestone changed from The Distant Future to Upstream Utopia

comment:6 Changed 9 years ago by jdreed

  • Status changed from new to closed
  • Resolution set to wontfix

There is nothing we care about that still has CUPS 1.3

Note: See TracTickets for help on using tickets.