Ticket #721 (closed defect: worksforme)

Opened 11 years ago

Last modified 11 years ago

mit-printing-config lpq sometimes tracebacks on Jaunty

Reported by: jdreed Owned by:
Priority: low Milestone: IAP 2011
Component: -- Keywords:
Cc: Fixed in version:
Upstream bug:

Description

      w20-575-44:~> lpq -Pajax                                                 
       Traceback (most recent call last):                                       
         File "/usr/bin/lpq", line 8, in <module>                               
           load_entry_point('debathena.printing==1.23.2-ubuntu9.04', 'console_sc
         File "/var/lib/python-support/python2.6/debathena/printing/lpq.py", lin
           sys.exit(_main(sys.argv)) # pragma: nocover                          
         File "/var/lib/python-support/python2.6/debathena/printing/lpq.py", lin
           s.connect((server, 515))                                             
         File "<string>", line 1, in connect                                    
       TypeError: coercing to Unicode: need string or buffer, NoneType found    

Further investigation reveals:

consult / printing / ezyang  16:37  (Edward Z. Yang)                         
       >>> from debathena.printing import common                                
       >>> common.find_queue('ajax')                                            
       (0, None, 'ajax')   

       >>> from debathena.printing import common                                
       >>> common.get_cups_uri('ajax')                                          
       u'file:///dev/null'                                                      
       >>> common.canonicalize_queue('ajax')    

       (yes, that last line is blank)                                                                                                

Further investigation is necessary to determine if this affects Jaunty, or just w20-575-44.

Change History

comment:1 Changed 11 years ago by jdreed

  • Status changed from new to closed
  • Resolution set to worksforme

Can't reproduce.

Note: See TracTickets for help on using tickets.