Ticket #764 (closed defect: fixed)

Opened 11 years ago

Last modified 11 years ago

Get libstdc++.so.5 on to the dialups

Reported by: jdreed Owned by: jweiss
Priority: blocker Milestone: Natty Alpha
Component: -- Keywords:
Cc: Fixed in version:
Upstream bug:

Description

The rest of the world still relies on this library, unfortunately, so we need to find a way to get it on to the dialups. (Discussions of why programs that still rely on this are Wrong(tm) is out of scope for this ticket.)

Conventional wisdom seems to be to install the amd64 version from here:
 http://packages.debian.org/stable/base/libstdc++5

and also download the i386 version from the same place, and use dpkg-deb to manually shove the i386 libraries in /usr/lib32.

We should possibly consider a compatibility package.

Change History

comment:1 Changed 11 years ago by andersk

No need to hijack a Debian package; libstdc++5 is  in lucid-backports.

(In maverick and later, libstdc++5 is back in the main repository, and /usr/lib32/libstdc++.so.5 is back in ia32-libs.)

comment:2 Changed 11 years ago by jdreed

So, in Lucid, the package is in backports, but is there an appropriate ia32libs package to install the 32-bit version on 64-bit lucid machines? Or do we still have to do that by hand?

Should we enable -backports on cluster and workstation (and the dialups), then? re there any potential screw cases to doing so?

comment:3 Changed 11 years ago by jdreed

We're blocking on a discussion of the implications of enabling -backports ( release-team:7266), and a good mechanism for keeping the 32-bit version of the library up to date if we install that by hand.

comment:4 Changed 11 years ago by jdreed

  • Owner set to jweiss
  • Status changed from new to assigned

This was discussed at release-team. We'll use backports (pinning back all packages except libstdc++5) for the amd64 version, and we'll update the 32-bit version by hand.

comment:5 Changed 11 years ago by jdreed

  • Status changed from assigned to proposed

I believe "proposed" in the dialup world is pronounced "test.dialup".

comment:6 Changed 11 years ago by jdreed

  • Status changed from proposed to closed
  • Resolution set to fixed

jweiss moved this to athena.dialup on 2/25.

Note: See TracTickets for help on using tickets.