Ticket #557 (closed defect: fixed)

Opened 11 years ago

Last modified 11 years ago

Update PXE installer for Lucid

Reported by: jdreed Owned by: amb
Priority: normal Milestone: Fall 2010
Component: installer Keywords:
Cc: Fixed in version:
Upstream bug:

Description

Because we don't have a ticket for this.

Change History

comment:1 Changed 11 years ago by jdreed

  • Component changed from -- to installer

comment:2 Changed 11 years ago by jdreed

  • Summary changed from Update installer for Lucid to Update PXE installer for Lucid

comment:3 Changed 11 years ago by amb

  • Status changed from new to assigned

For the record, what's currently on the PXE server is below. (Note that DNS is unreliable in this environment, thus the hardcoded address for demeter.)

default ks
label ks

kernel vmlinuz
append netcfg/get_hostname= locale=en_US console-setup/layoutcode=us interface=auto url= http://18.9.60.73/installer/jaunty/debathena-jaunty.preseed initrd=initrd.img

comment:4 Changed 11 years ago by amb

It's available for testing now via option 9. It should also be autodetecting i386 vs. amd64.

There are still some preseed options that don't work properly, and install-debathena.sh still blows out, though.

comment:5 Changed 11 years ago by jdreed

This is mostly done. The installer occasionally fails non-deterministically and barfs in pkgsel, causing it to full install debathena-cluster, and then fully uninstall it.

Additional testing is required and would be helpful. This may or may not be limited to amd64.

comment:6 Changed 11 years ago by jdreed

  • Status changed from assigned to closed
  • Resolution set to fixed

This is done, we tracked down install failures to #666 and #667

comment:7 Changed 11 years ago by amb

  • Priority changed from critical to major
  • Status changed from closed to reopened
  • Resolution fixed deleted
  • Milestone changed from Summer 2010 (Lucid Deploy) to Fall 2010

The PXE setup should really be installing Lucid directly, not via Jaunty. The "vanilla install" option should also provide Jaunty.

See also #333, which this will probably fix with no additional work.

comment:8 Changed 11 years ago by amb

  • Status changed from reopened to closed
  • Resolution set to fixed

This got fixed a while ago. We're still using a front-end loader which happens to be the jaunty install kernel and then kexecing what we really want, but the "vanilla" option has been switched to Lucid as well.

Note: See TracTickets for help on using tickets.